Ford F150 electrical gremlins? recent failures of electrical accessories.?

I have a 2000 ford f150 Lariat 4×4 and recently funny things have been happening. one component or other fails for a while then comes back. It is as if the electric power to the component is gone and then maybe 5 minutes later it comes back. What is so unusual is there are several accessories that are affected at different times. The affected Accessoriess are the radio, power windows, windshield wipers, interior lights, odometer display, right side power door lock, and today the truck will not come out of park with the brake pedal depressed and the engine running. The check engine light has not been on (therefore no OBD codes) but the ABS anti lock brake) light has been on the dash for the last 2 weeks. Any insight into this? I am totally perplexed and know enough to fix the problem if I only knew where to start. I would appreciate someone’s expertise.

, , , , , , , , , , ,

3 Responses to Ford F150 electrical gremlins? recent failures of electrical accessories.?

  1. cblack6540 June 1, 2009 at 8:23 pm #

    Sounds like you have a bad grounding problem, check the negative wire from your battery, make sure is is grounded to the frame somewhere. and on the rear of your engine on the passenger side is a ground wire to the firewall. Check to see if they are O.K. if you still have a problem i would run an extra ground wire.

  2. piggybackhauler June 1, 2009 at 8:23 pm #

    was this car one of them that survived water damage due to a hurricane and passed off as cherry?

  3. Me June 1, 2009 at 8:23 pm #

    Most likly the GEM module go here: http://www.ford-trucks.com/forums/517872-gem-module-problem.html.